PatCatNat’s, site de Patrice MOREL
Vous êtes ici : Accueil » Inform@tic » Excel ou Calc » Tests logiques et Conditions : Si/Ou/et autres...)

Tests logiques et Conditions : Si/Ou/et autres...)

D 7 novembre 2006     H 15:41     A Patrice MOREL    


SI

SI (G43=0;"C'est pas bien";G22)
SI ( Condition ; Réponse si Vrai ; Réponse si Faux )

SI (G43=0;0;SI (G43<=250;250;SI (G43>=0;G43;0)))
La dernière réponse doit être celle répondant au critère Faux (Le maximum étant 7 conditions).

LibreOffice_CalcLe SI est souvent employé pour afficher une cellule vide si elle est égale à 0 : SI (A1="";"";A1)
Dans Excel la somme des cellule comportant ces formule fonctionne mais dans Calc de Libre Office cette même opération met en erreur (#VALEUR).
Effectivement, Calc ne peut pas additionner de "chaînes de caractères" !
_La façon de détourner le problème est dans le formatage de la cellule :
L’idée est de dire que si la cellule est égale à 0, ne pas mettre de couleur. Il faut ajoutyer au format de la cellule un point virgule et un dièse (;#).
Exemple :
Format de cellule en euro qui s’affiche en couleur par défaut si positif ou rouge si négatif (avec séparateur de milliers) : # ##0,00 [$€-40C] ;[RED]-# ##0,00 [$€-40C]
Le même format qui indique que si ni négatif, ni positif alors aucune couleur : # ##0,00 [$€-40C] ;[RED]-# ##0,00 [$€-40C] ;#

OU

=OU(VRAI)
Un argument est VRAI (VRAI)

=OU(1+1=1;2+2=5)
Tous les arguments ont pour résultat FAUX (FAUX)

=OU(VRAI;FAUX;VRAI)
Au moins un argument est VRAI (VRAI)

Exemple avec SI et OU

Cas des cellules vides donnant comme résultat #Div/0 ! alors que l’on veut connaître l’évolution de la 1ère classe par rapport à la seconde classe.

1ère 2ème Évolution 1ère/2ème Résultat
360 =SI(OU(B3<>"" ;A3<>"")=FAUX ;0 ;SI(B3="" ;100% ;A3/B3-1)) -100%
360 =SI(OU(B4<>"" ;A4<>"")=FAUX ;0 ;SI(B4="" ;100% ;A4/B4-1)) 100%

SOMMEPROD (X conditions)

Formule qui permet de calculer la somme des Valeurs comportant le nom "Critère 3" avec la position "NO" et "Tiva".

Exemple :

Onglet appelé "Onglet" :

Le résultat doit donner dans un autre onglet :

Le code en B4 :

=SOMMEPROD((Onglet!A2:A20=B1)*(Onglet!B2:B20=B2)*(Onglet!C2:C20="Tiva");(Onglet!D2:D20))

Décorticage :

(Onglet!A2:A20=B1)*(Onglet!B2:B20=B2)*(Onglet!C2:C20="Tiva")
Correspond aux critères.

(Onglet!D2:D20)
Correspond au résultat attendu.

Note : Les critères ne fonctionnent pas sur des colonnes. Il faut des plages de cellules !

Mise en forme conditionnelle

Pour mettre en forme une cellule si elle est vide :

Dans la barre de menu aller à Format et Mise en forme conditionnelle...
Le type de condition "La formule est" teste une fonction logique. L’expression utilisée dans vos mises en forme conditionnelles doit donc renvoyer un résultat Vrai ou Faux.
Il faut alors utiliser la fonction ESTVIDE

Exemples :

Si l’on veut que la cellule C3 utilise cette mise en forme conditionnelle :
La cellule C3 sélectionnée, dans le champ au regard de "La formule est" mettre ESTVIDE(C3)

On peut aussi imaginer que si la cellule C1 est vide, C3 utilise la mise en forme conditionnelle :
Toujours la cellule C3 sélectionnée, dans le champ au regard de "La formule est" mettre ESTVIDE(C1)

Un autre exemple : =SI($A$3<AUJOURDHUI();VRAI;FAUX)
Renvoie une valeur VRAI si la date saisie en A3 est antérieure à aujourd’hui.

Remarque : Les critères de type TEXTE doivent être encadrés par des guillemets.

Autre utilité pour une condition par rapport à une autre cellule (nous sommes dans une cellule différente des 2 citées ci-après...) :

"La formule est" =(B29=$A$2)

Dans ce cas c’est : si B29 est égal à A2


Autre fonctions logiques spécifiques :
- ET
- FAUX
- NON
- OU
- VRAI
- EST.IMPAIR
- EST.PAIR
- ESTERREUR
- ESTLOGIQUE
- ESTNA
- ESTNONTEXTE
- ESTNUM
- ESTREF
- ESTTEXTE
- ESTVIDE
- EXACT

Trouvé sur la mine d’or : Développez.com


Validation conditionnelle

Pour accepter une saisie si une autre cellule possède une certaine valeur :

Dans la barre de menu aller à Autoriser et Validation...
Onglet Options "La formule est" choisir Personnalisé.
La case Ignorer si vide doit être décochée.
A Formule mettre votre ou vos conditions.

Les 2 autres onglets servent aux messages des boîtes de dialogues.

Exemple :

Si l’on veut que la cellule C3 possède le mot "Ok" et que la cellule D4 ne soit pas vide pour autoriser la saisie en C4, la Formule de la cellule C4 sera :
=ET(C3="Ok";D4<>"")

Dans la même rubrique

4 janvier – Incrémentation de lignes avec un classeur lié.

3 août 2017 – Nom de fichier dans une cellule

14 mars 2012 – Date par défaut

14 décembre 2011 – Divers petits trucs

17 octobre 2011 – Préparer sa liste de diffusion par mail